ajax loader

Esqueceu sua senha?

Sintaxe do PHP não funciona em versão PHP 5.3.x ou inferior

Eu recentemente instalei o PHP 5.3.5sobre o meu sistema Linux e meu antigo código phpnão funciona mais. Ele exibe o código nas páginas que se encontra dentro da sintaxe php <? ... meu código ... ?>. Como faço para corrigir este problema?

Você precisa ativar a sintaxe curta do php editando o arquivo de configuração php.ini. O uso de sintaxes curtas, deve ser evitado ao desenvolver aplicações ou bibliotecas com intenção de redistribuição ou usadas em servidores PHP que não estão sob seu controle, porque as sintaxes curtas podem não ser suportadas no servidor de destino. Para código portável, redistribuível, tenha certeza de não usar sintaxes curtas.

# Procure por seu arquivo de configuração php.ini
# depois edite com o seguinte comando
 
nano php.ini

Substitua a seguinte linha:

short_open_tag = Off

por

short_open_tag = On

Salve e feche o arquivo. Não se esqueça de reiniciar o servidor web Apache:

apachectl -k restart

ou

service httpd restart


18/10/2011 às 04:14    acessos (6286)     rodr1go

Gostaria de deixar o seu comentário? Para deixar o seu comentário por favor faça o registro em nosso site.   Registrar